#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https://mega\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))"
Local $sString = "https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz" & @CRLF & _
"https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz" & @CRLF & _
"" & @CRLF & _
"https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb" & @CRLF & _
"https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")