re = /https:\/\/mega\.nz\/((folder|file)\/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))/m
str = 'https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb
https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end