$re = '@https://mega\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))@m';
$str = 'https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb
https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);