package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://mega\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))`)
var str = `https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb
https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}