import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://mega\\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))";
final String string = "https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz\n"
+ "https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz\n\n"
+ "https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb\n"
+ "https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}