using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://mega\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))";
string input = @"https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb
https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}