// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$").unwrap();
let string = "Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}