package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$`)
var str = `Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}