const regex = /^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$', 'g')
const str = `Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}