import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$";
final String string = "Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}