re = /^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$/
str = 'Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end