using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$";
string input = @"Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}