$re = '/^(?<security>.*) Stock Rating Reaffirmed (at|by) (?<analyst>.*)$/';
$str = 'Barclays PLC’s (BCS) “Neutral” Rating Reaffirmed at JPMorgan Chase & Co.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);