import Foundation
let pattern = #"^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
14½ oz gin
¾ oz fresh lemon juice
½ oz Lillet Blanc
0,5 dash angostura
1/2 oz Lillet Blanc
½ oz white crème de cacaot
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)