#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s"
Local $sString = "14½ oz gin" & @CRLF & _
"¾ oz fresh lemon juice" & @CRLF & _
"½ oz Lillet Blanc" & @CRLF & _
"0,5 dash angostura" & @CRLF & _
"1/2 oz Lillet Blanc" & @CRLF & _
"½ oz white crème de cacaot"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")