// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s").unwrap();
let string = "14½ oz gin
¾ oz fresh lemon juice
½ oz Lillet Blanc
0,5 dash angostura
1/2 oz Lillet Blanc
½ oz white crème de cacaot";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}