re = /^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s/m
str = '14½ oz gin
¾ oz fresh lemon juice
½ oz Lillet Blanc
0,5 dash angostura
1/2 oz Lillet Blanc
½ oz white crème de cacaot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end