using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s";
string input = @"14½ oz gin
¾ oz fresh lemon juice
½ oz Lillet Blanc
0,5 dash angostura
1/2 oz Lillet Blanc
½ oz white crème de cacaot";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}