import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9¼½¾]*|[0-9](\\/|,|.)[0-9])\\s(oz|cup|tsp|tbsp|dash)?\\s";
final String string = "14½ oz gin\n"
+ "¾ oz fresh lemon juice\n"
+ "½ oz Lillet Blanc\n"
+ "0,5 dash angostura\n"
+ "1/2 oz Lillet Blanc\n"
+ "½ oz white crème de cacaot";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}