import Foundation
let pattern = #"((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
jair bolsonaro
jair messisas bolsonaro
bolsonaro
presidente jair bolsonaro
presidente jair messias bolsonaro
JAIR bolsonaro
Boldo
Bilonaro
Biroliro
Biroslau
Biroslini
Biruleibes
Bobonaro
Bolno
Bololaro
Bolonaro
Bolossauro
Bolovo
Bolro
Bolso
Bolsoanta
Bolsobitch
Bolsobostão
Bolsolini
Bolsonabo
bolsonazi
Bolzonóquio
Bolzy
Bonobo
Boslo
Bostonauro
Bostossauro
Bozolino
Bozonabo
Bubobauro
Burronaro
Capetão
Chihuahua do Trump
Coisa
Coiso
Frouxonaro
Javier Bolsossauro
Nalbossauro
Salnorabo
Silvonaro
Soldado Bizonho
Solnorabo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)