import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))";
final String string = "jair bolsonaro\n"
+ "jair messisas bolsonaro\n"
+ "bolsonaro\n"
+ "presidente jair bolsonaro\n"
+ "presidente jair messias bolsonaro\n"
+ "JAIR bolsonaro\n"
+ "Boldo\n"
+ "Bilonaro\n"
+ "Biroliro\n"
+ "Biroslau\n"
+ "Biroslini\n"
+ "Biruleibes\n"
+ "Bobonaro\n"
+ "Bolno\n"
+ "Bololaro\n"
+ "Bolonaro\n"
+ "Bolossauro\n"
+ "Bolovo\n"
+ "Bolro\n"
+ "Bolso\n"
+ "Bolsoanta\n"
+ "Bolsobitch\n"
+ "Bolsobostão\n"
+ "Bolsolini\n"
+ "Bolsonabo\n"
+ "bolsonazi\n"
+ "Bolzonóquio\n"
+ "Bolzy\n"
+ "Bonobo\n"
+ "Boslo\n"
+ "Bostonauro\n"
+ "Bostossauro\n"
+ "Bozolino\n"
+ "Bozonabo\n"
+ "Bubobauro\n"
+ "Burronaro\n"
+ "Capetão\n"
+ "Chihuahua do Trump\n"
+ "Coisa\n"
+ "Coiso\n"
+ "Frouxonaro\n"
+ "Javier Bolsossauro\n"
+ "Nalbossauro\n"
+ "Salnorabo\n"
+ "Silvonaro\n"
+ "Soldado Bizonho\n"
+ "Solnorabo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}