// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))").unwrap();
let string = "jair bolsonaro
jair messisas bolsonaro
bolsonaro
presidente jair bolsonaro
presidente jair messias bolsonaro
JAIR bolsonaro
Boldo
Bilonaro
Biroliro
Biroslau
Biroslini
Biruleibes
Bobonaro
Bolno
Bololaro
Bolonaro
Bolossauro
Bolovo
Bolro
Bolso
Bolsoanta
Bolsobitch
Bolsobostão
Bolsolini
Bolsonabo
bolsonazi
Bolzonóquio
Bolzy
Bonobo
Boslo
Bostonauro
Bostossauro
Bozolino
Bozonabo
Bubobauro
Burronaro
Capetão
Chihuahua do Trump
Coisa
Coiso
Frouxonaro
Javier Bolsossauro
Nalbossauro
Salnorabo
Silvonaro
Soldado Bizonho
Solnorabo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}