const regex = /((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))', 'gm')
const str = `jair bolsonaro
jair messisas bolsonaro
bolsonaro
presidente jair bolsonaro
presidente jair messias bolsonaro
JAIR bolsonaro
Boldo
Bilonaro
Biroliro
Biroslau
Biroslini
Biruleibes
Bobonaro
Bolno
Bololaro
Bolonaro
Bolossauro
Bolovo
Bolro
Bolso
Bolsoanta
Bolsobitch
Bolsobostão
Bolsolini
Bolsonabo
bolsonazi
Bolzonóquio
Bolzy
Bonobo
Boslo
Bostonauro
Bostossauro
Bozolino
Bozonabo
Bubobauro
Burronaro
Capetão
Chihuahua do Trump
Coisa
Coiso
Frouxonaro
Javier Bolsossauro
Nalbossauro
Salnorabo
Silvonaro
Soldado Bizonho
Solnorabo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}