using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))";
string input = @"jair bolsonaro
jair messisas bolsonaro
bolsonaro
presidente jair bolsonaro
presidente jair messias bolsonaro
JAIR bolsonaro
Boldo
Bilonaro
Biroliro
Biroslau
Biroslini
Biruleibes
Bobonaro
Bolno
Bololaro
Bolonaro
Bolossauro
Bolovo
Bolro
Bolso
Bolsoanta
Bolsobitch
Bolsobostão
Bolsolini
Bolsonabo
bolsonazi
Bolzonóquio
Bolzy
Bonobo
Boslo
Bostonauro
Bostossauro
Bozolino
Bozonabo
Bubobauro
Burronaro
Capetão
Chihuahua do Trump
Coisa
Coiso
Frouxonaro
Javier Bolsossauro
Nalbossauro
Salnorabo
Silvonaro
Soldado Bizonho
Solnorabo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}