# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))"
test_str = ("jair bolsonaro\n"
"jair messisas bolsonaro\n"
"bolsonaro\n"
"presidente jair bolsonaro\n"
"presidente jair messias bolsonaro\n"
"JAIR bolsonaro\n"
"Boldo\n"
"Bilonaro\n"
"Biroliro\n"
"Biroslau\n"
"Biroslini\n"
"Biruleibes\n"
"Bobonaro\n"
"Bolno\n"
"Bololaro\n"
"Bolonaro\n"
"Bolossauro\n"
"Bolovo\n"
"Bolro\n"
"Bolso\n"
"Bolsoanta\n"
"Bolsobitch\n"
"Bolsobostão\n"
"Bolsolini\n"
"Bolsonabo\n"
"bolsonazi\n"
"Bolzonóquio\n"
"Bolzy\n"
"Bonobo\n"
"Boslo\n"
"Bostonauro\n"
"Bostossauro\n"
"Bozolino\n"
"Bozonabo\n"
"Bubobauro\n"
"Burronaro\n"
"Capetão\n"
"Chihuahua do Trump\n"
"Coisa\n"
"Coiso\n"
"Frouxonaro\n"
"Javier Bolsossauro\n"
"Nalbossauro\n"
"Salnorabo\n"
"Silvonaro\n"
"Soldado Bizonho\n"
"Solnorabo")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.