#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?i)(Jair .*bolsonaro)|(bolsonaro)|(presidente .*bolsonaro)|(bilonaro)|(biroliro)|(biroslau)|(biroslini)|(biruleibes)|(bobonaro)|(bolno)|(bololaro)|(bolonaro)|(bolossauro)|(bolovo)|(bolro)|(bolso)|(bolsoanta)|(bolsobitch)|(bolsobostão)|(bolsolini)|(bolsonabo)|(bolzonóquio)|(bolzy)|(bonobo)|(boslo)|(bostonauro)|(bostossauro)|(bozolino)|(bozonabo)|(bubobauro)|(burronaro)|(capetão)|(chihuahua do Trump)|(coisa)|(coiso)|(frouxonaro)|(javier Bolsossauro)|(nalbossauro)|(salnorabo)|(silvonaro)|(soldado Bizonho)|(solnorabo)|(bolsonazi))"
Local $sString = "jair bolsonaro" & @CRLF & _
"jair messisas bolsonaro" & @CRLF & _
"bolsonaro" & @CRLF & _
"presidente jair bolsonaro" & @CRLF & _
"presidente jair messias bolsonaro" & @CRLF & _
"JAIR bolsonaro" & @CRLF & _
"Boldo" & @CRLF & _
"Bilonaro" & @CRLF & _
"Biroliro" & @CRLF & _
"Biroslau" & @CRLF & _
"Biroslini" & @CRLF & _
"Biruleibes" & @CRLF & _
"Bobonaro" & @CRLF & _
"Bolno" & @CRLF & _
"Bololaro" & @CRLF & _
"Bolonaro" & @CRLF & _
"Bolossauro" & @CRLF & _
"Bolovo" & @CRLF & _
"Bolro" & @CRLF & _
"Bolso" & @CRLF & _
"Bolsoanta" & @CRLF & _
"Bolsobitch" & @CRLF & _
"Bolsobostão" & @CRLF & _
"Bolsolini" & @CRLF & _
"Bolsonabo" & @CRLF & _
"bolsonazi" & @CRLF & _
"Bolzonóquio" & @CRLF & _
"Bolzy" & @CRLF & _
"Bonobo" & @CRLF & _
"Boslo" & @CRLF & _
"Bostonauro" & @CRLF & _
"Bostossauro" & @CRLF & _
"Bozolino" & @CRLF & _
"Bozonabo" & @CRLF & _
"Bubobauro" & @CRLF & _
"Burronaro" & @CRLF & _
"Capetão" & @CRLF & _
"Chihuahua do Trump" & @CRLF & _
"Coisa" & @CRLF & _
"Coiso" & @CRLF & _
"Frouxonaro" & @CRLF & _
"Javier Bolsossauro" & @CRLF & _
"Nalbossauro" & @CRLF & _
"Salnorabo" & @CRLF & _
"Silvonaro" & @CRLF & _
"Soldado Bizonho" & @CRLF & _
"Solnorabo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")