import Foundation
let pattern = #"(?:<link[^>]+components/bitrix|(?:src|href)=\"/bitrix/(?:js|templates))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
src="/bitrix/templates/1c-bitrix-new/images/vlogo.png"
src="/bitrix/templates/1c-bitrix-new/images/16.png"
src="/bitrix/js/main/core/core_db.min.js?14328132264928"
href="/bitrix/js/main/core/css/core_image.min.css?14293595955405"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)