re = /(?:<link[^>]+components\/bitrix|(?:src|href)=\"\/bitrix\/(?:js|templates))/m
str = 'src="/bitrix/templates/1c-bitrix-new/images/vlogo.png"
src="/bitrix/templates/1c-bitrix-new/images/16.png"
src="/bitrix/js/main/core/core_db.min.js?14328132264928"
href="/bitrix/js/main/core/css/core_image.min.css?14293595955405"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end