import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<link[^>]+components/bitrix|(?:src|href)=\\\"/bitrix/(?:js|templates))";
final String string = "src=\"/bitrix/templates/1c-bitrix-new/images/vlogo.png\"\n"
+ "src=\"/bitrix/templates/1c-bitrix-new/images/16.png\"\n"
+ "src=\"/bitrix/js/main/core/core_db.min.js?14328132264928\"\n"
+ "href=\"/bitrix/js/main/core/css/core_image.min.css?14293595955405\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}