using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<link[^>]+components/bitrix|(?:src|href)=\""/bitrix/(?:js|templates))";
string input = @"src=""/bitrix/templates/1c-bitrix-new/images/vlogo.png""
src=""/bitrix/templates/1c-bitrix-new/images/16.png""
src=""/bitrix/js/main/core/core_db.min.js?14328132264928""
href=""/bitrix/js/main/core/css/core_image.min.css?14293595955405""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}