// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:<link[^>]+components/bitrix|(?:src|href)=\"/bitrix/(?:js|templates))"#).unwrap();
let string = "src=\"/bitrix/templates/1c-bitrix-new/images/vlogo.png\"
src=\"/bitrix/templates/1c-bitrix-new/images/16.png\"
src=\"/bitrix/js/main/core/core_db.min.js?14328132264928\"
href=\"/bitrix/js/main/core/css/core_image.min.css?14293595955405\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}