// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$").unwrap();
let string = "$0.1250 <br>/ <br>
QTR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}