using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$";
string input = @"$0.1250 <br>/ <br>
QTR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}