package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$`)
var str = `$0.1250 <br>/ <br>
QTR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}