#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$"
Local $sString = "$0.1250 <br>/ <br>" & @CRLF & _
" QTR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")