re = /^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$/m
str = '$0.1250 <br>/ <br>
QTR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end