const regex = /^(CA|US)?\$((\d{0,})(\.\d{0,})?)([M|B]?)((\s| |<br\s*\/?>)*\/(\s| |<br\s*\/?>)*(MTH|QTR|Y|YEAR) ?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(CA|US)?\\$((\\d{0,})(\\.\\d{0,})?)([M|B]?)((\\s| |<br\\s*\\\/?>)*\\\/(\\s| |<br\\s*\\\/?>)*(MTH|QTR|Y|YEAR) ?)?$', 'gm')
const str = `\$0.1250 <br>/ <br>
QTR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}