import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(CA|US)?\\$((\\d{0,})(\\.\\d{0,})?)([M|B]?)((\\s| |<br\\s*\\/?>)*\\/(\\s| |<br\\s*\\/?>)*(MTH|QTR|Y|YEAR) ?)?$";
final String string = "$0.1250 <br>/ <br>\n"
+ " QTR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}