import Foundation
let pattern = #"(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
edgedb://e_db:pass@host:5656/dbname?tls_security=insecure
edgedb://e_db:pass@host:5656/dbname
edgedb://e_db:pass@host:5656/
edgedb://e_db:pass@host:5656
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)