import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<protocol>edgedb:\\/\\/)(?<user>(?:\\w|\\d)+):(?<pwd>(?:\\w|\\d)+)@(?<host>(?:\\w|\\d)+):(?<port>(?:\\d)+)\\/?(?<db>(?:\\w|\\d)+)?(?<params>\\/?.*)$";
final String string = "edgedb://e_db:pass@host:5656/dbname?tls_security=insecure\n"
+ "edgedb://e_db:pass@host:5656/dbname\n"
+ "edgedb://e_db:pass@host:5656/\n"
+ "edgedb://e_db:pass@host:5656";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}