#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$"
Local $sString = "edgedb://e_db:pass@host:5656/dbname?tls_security=insecure" & @CRLF & _
"edgedb://e_db:pass@host:5656/dbname" & @CRLF & _
"edgedb://e_db:pass@host:5656/" & @CRLF & _
"edgedb://e_db:pass@host:5656"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")