// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$").unwrap();
let string = "edgedb://e_db:pass@host:5656/dbname?tls_security=insecure
edgedb://e_db:pass@host:5656/dbname
edgedb://e_db:pass@host:5656/
edgedb://e_db:pass@host:5656";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}