re = /(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$/m
str = 'edgedb://e_db:pass@host:5656/dbname?tls_security=insecure
edgedb://e_db:pass@host:5656/dbname
edgedb://e_db:pass@host:5656/
edgedb://e_db:pass@host:5656'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end