const regex = /(?<protocol>edgedb:\/\/)(?<user>(?:\w|\d)+):(?<pwd>(?:\w|\d)+)@(?<host>(?:\w|\d)+):(?<port>(?:\d)+)\/?(?<db>(?:\w|\d)+)?(?<params>\/?.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<protocol>edgedb:\\\/\\\/)(?<user>(?:\\w|\\d)+):(?<pwd>(?:\\w|\\d)+)@(?<host>(?:\\w|\\d)+):(?<port>(?:\\d)+)\\\/?(?<db>(?:\\w|\\d)+)?(?<params>\\\/?.*)$', 'gm')
const str = `edgedb://e_db:pass@host:5656/dbname?tls_security=insecure
edgedb://e_db:pass@host:5656/dbname
edgedb://e_db:pass@host:5656/
edgedb://e_db:pass@host:5656`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}