// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)").unwrap();
let string = "Page 102 of 10
Slide 10 of 10
Page 102 / 10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}