using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)";
string input = @"Page 102 of 10
Slide 10 of 10
Page 102 / 10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}