re = /.*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)/m
str = 'Page 102 of 10
Slide 10 of 10
Page 102 / 10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end