$re = '/.*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)/m';
$str = 'Page 102 of 10
Slide 10 of 10
Page 102 / 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);