package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)`)
var str = `Page 102 of 10
Slide 10 of 10
Page 102 / 10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}