use strict;
my $str = 'Page 102 of 10
Slide 10 of 10
Page 102 / 10';
my $regex = qr/.*\s([[:digit:]]*)\s(?:of|[\/])\s([[:digit:]]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}